Outage: ACL Academy
Incident Report for HighBond
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 22, 2018 - 20:54 PDT
Investigating


We are currently investigating the outage and will provide further updates.

For any questions, please contact ACL Support: https://support.acl.com
Posted 10 months ago. Oct 22, 2018 - 17:44 PDT
This incident affected: Help & Learning (Galvanize Academy).